Home Tutorials Download Beta Store Forum Documentation KnowledgeBase Wiki Blog

ShiVa3D

Return to User contributions

[iPhone] adWhirl/iAd working solution

[iPhone] adWhirl/iAd working solution

Postby dpharaoh » 17 Jul 2010, 02:43

OK, a couple of users have tested it, and I will go ahead and make this available. It took several days to create, so feel free to give something back via paypal (dave@brooklawnstudios.com)

http://www.daveyounggames.com/ShivaAddons/Shiva_AdWhirl_iPhone.zip

Instructions are inside. It has taken a couple of users a total of 10-15 minutes each to get working.

A sample Shiva game with ads in it is included. Enjoy!
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1519
Location: New Bedford, MA

Re: [iPhone] adWhirl/iAd working solution

Postby dpharaoh » 19 Jul 2010, 19:28

I neglected to mention: if anyone has some troubles with this, or improvements, please let me know :)
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1519
Location: New Bedford, MA

Re: [iPhone] adWhirl/iAd working solution

Postby Markuzzzz » 19 Jul 2010, 21:10

Hi dpharaoh,

It's great! Thanx so much, I will go and test it wednesday :) can't wait.

Kind regards,

Markus
Markuzzzz
Platinum Boarder
Platinum Boarder
 
Posts: 578
Location: Netherlands

Re: [iPhone] adWhirl/iAd working solution

Postby almighty » 21 Jul 2010, 10:36

Hi dpharaoh,
thank you so much for this, we'll take a look at it very soon.
almighty
Gold Boarder
Gold Boarder
 
Posts: 186
Location: ROMA

Re: [iPhone] adWhirl/iAd working solution

Postby shoaz » 07 Sep 2010, 14:47

hi dpharaoh,
I need some help with your work :
I followed the instructions, and in xCode, the debug succeed.
But when I launch the example app, just after the splash screen, the app crash and back to the home screen. Same result with simulator (iPhone simulator 4) and with my device (iPhone 3G with iPhone OS 3.1.3).

If you have time to help me find what I missed, it would be great.
User avatar
shoaz
Expert Boarder
Expert Boarder
 
Posts: 104
Location: Rennes

Re: [iPhone] adWhirl/iAd working solution

Postby dpharaoh » 07 Sep 2010, 16:02

It would help significantly if you could post something of the crash information from xcode.
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1519
Location: New Bedford, MA

Re: [iPhone] adWhirl/iAd working solution

Postby shoaz » 07 Sep 2010, 17:18

sorry, don't have dev reflex... :oops:
this is the message from the console just after the crash test :
"07/09/10 18:46:17 Xcode[128] Error launching simulated application: Error Domain=DTiPhoneSimulatorErrorDomain Code=1 UserInfo=0x2ce1160 "Simulateur iPhone n’a pas pu trouver l’identifiant de processus de com.tamkari.testAppli."
And I don't understand, because "com.tamkari.testAppli" match exactly the App ID mentioned in the provisioning portal.
User avatar
shoaz
Expert Boarder
Expert Boarder
 
Posts: 104
Location: Rennes

Re: [iPhone] adWhirl/iAd working solution

Postby shoaz » 07 Sep 2010, 17:19

xCode message in english could be "IPhone Simulator failed to find the process identifier com.tamkari.testAppli."
User avatar
shoaz
Expert Boarder
Expert Boarder
 
Posts: 104
Location: Rennes

Re: [iPhone] adWhirl/iAd working solution

Postby dpharaoh » 07 Sep 2010, 19:34

Ah. Try building the app in release, and then MANUALLY installing it in xcode and run it. I often have problems trying to run Shiva games FROM xcode.
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1519
Location: New Bedford, MA

Re: [iPhone] adWhirl/iAd working solution

Postby shoaz » 07 Sep 2010, 23:14

you mean : build the app without debug or run, explore the xCode project folder, find the right file in the "build" folder, and with the organizer, drag this file in the device to install it?
If this interpretation is right, I always have the problem... :cry:(crash just after splash screen)
User avatar
shoaz
Expert Boarder
Expert Boarder
 
Posts: 104
Location: Rennes

Re: [iPhone] adWhirl/iAd working solution

Postby dpharaoh » 08 Sep 2010, 03:43

With which version of the SDK?
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1519
Location: New Bedford, MA

Re: [iPhone] adWhirl/iAd working solution

Postby shoaz » 08 Sep 2010, 12:55

xcode 3.2.3 with iOS sdk 4.0.2
User avatar
shoaz
Expert Boarder
Expert Boarder
 
Posts: 104
Location: Rennes

Re: [iPhone] adWhirl/iAd working solution

Postby dpharaoh » 08 Sep 2010, 14:58

I haven't tried in the latest edition of xcode/os. Did you make sure to change your publisherid in the AdWhirlAI module, and also your product id in the xcode project (com.somebody.productname)?
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1519
Location: New Bedford, MA

Re: [iPhone] adWhirl/iAd working solution

Postby broozar » 08 Sep 2010, 15:08

btw, i added this to the wiki: http://www.stonetrip.com/developer/wiki/index.php?title=Apple_iOS_Devices

the file pack is on your own server, right? if anyone is willing to host it as well, it might cut traffic for dave and increase reliability.

Image
User avatar
broozar
Platinum Boarder
Platinum Boarder
 
Posts: 3451
Location: Berlin - Germany

Re: [iPhone] adWhirl/iAd working solution

Postby dpharaoh » 08 Sep 2010, 15:28

It is indeed, but I lease a dedicated server and foresee needing it for many years :)
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1519
Location: New Bedford, MA

Next

Return to User contributions