Home Tutorials Download Beta Store Forum Documentation KnowledgeBase Wiki Blog

ShiVa3D

Return to Bugs

Device App Loader url incorrect or not launch in ShiVa  [FIXED]

Report bugs and issues

Device App Loader url incorrect or not launch in ShiVa

Postby Winin » 14 Mar 2011, 19:53

Hi, I'm trying to get the Device App Loader to work, but I'm stuck. I compiled it and loaded it onto my DroidX. I can run it (though the input simulator crashes the app). The Device Loader brings up the URL window. I've started the loader in ShiVa, and I've typed in the url as listed. But then I get an error: "Url incorrect or Device app loader not launch in ShiVa".

I've triple checked that the url is correct. I've stopped/started the server. Set it to start automatically and restarted ShiVa, turned my firewall off, nothing works. I have set an export folder (where my stk's are stored). My phone is on WiFi on the same network as my computer.

Am I missing something? Help says I should be able to get a file list.

Thanks.
User avatar
Winin
Expert Boarder
Expert Boarder
 
Posts: 82
Location: San Francisco

Re: Device App Loader url incorrect or not launch in ShiVa

Postby mpotter » 11 Apr 2011, 19:44

Somebody please help with this.

I run the Developer Tools app on my DroidX and select the Device App Loader option and it asks me for the URL. I go into ShiVa3D into the Settings and I turn on the Device App Loader. I set it to start automatically with ShiVa and set the Export folder to the folder containing my app export. I Start the server and then I enter the URL into the Android App Loader URL field. My computer (running the ShiVa3D server) and my DroidX phone are both on the same local wifi network. Server is running Windows 7.

I get a blank window below the URL. Looks like this is where the exported apps are supposed to be displayed, but nothing is displayed. I don't get any error message like the original poster. But it doesn't work.

Is there any error log anywhere that might show me what isn't working?
mpotter
Junior Boarder
Junior Boarder
 
Posts: 34

Re: Device App Loader url incorrect or not launch in ShiVa

Postby mpotter » 11 Apr 2011, 20:14

Nevermind, answering my own question:

When building the ShiVa DDT application, in the Build options of the Authoring Tool, you need to be sure and enable the "Use Network" option. Once I did this and reinstalled DDT on my phone, then my list of exported applications was properly displayed.
mpotter
Junior Boarder
Junior Boarder
 
Posts: 34

Re: Device App Loader url incorrect or not launch in ShiVa

Postby Winin » 11 Apr 2011, 20:22

Cool, thanks for the info. I'll give that a shot.
User avatar
Winin
Expert Boarder
Expert Boarder
 
Posts: 82
Location: San Francisco

Re: Device App Loader url incorrect or not launch in ShiVa

Postby Winin » 12 Apr 2011, 17:10

Nope, I still get the same error. I wonder if there is a firewall issue or do I need the Shiva server running? I've turned off my firewall, but no luck. Maybe in my router?
User avatar
Winin
Expert Boarder
Expert Boarder
 
Posts: 82
Location: San Francisco

Re: Device App Loader url incorrect or not launch in ShiVa

Postby Yopia » 12 Apr 2011, 17:34

Hi,

Yes of course you have to open the port you enter in the settings
or try an already opened port.
User avatar
Yopia
Platinum Boarder
Platinum Boarder
 
Posts: 630

Re: Device App Loader url incorrect or not launch in ShiVa

Postby Winin » 12 Apr 2011, 17:57

Nope that's not it. I have port 5354 forwarded, so I tried that (shiva server uses the same one, but it isn't running). My firewall on my PC is disabled, the App loader is running in ShiVa, and I built the DDT with the network option.

Do I need the ShiVa Server running? If so, what application ID would I use? Is there an updated instruction document for setting this up? Maybe I've been looking at an old version and missed something? Is there some other build setting I need for the DDT?

Thanks. This will make life much easier since I'm doing lots of little changes to get my FPS up on my phone.
User avatar
Winin
Expert Boarder
Expert Boarder
 
Posts: 82
Location: San Francisco

Re: Device App Loader url incorrect or not launch in ShiVa

Postby Yopia » 12 Apr 2011, 21:03

ShiVa Server is not needed at all.
You just have to launch the the 'Device App loader' in the ShiVa settings, allow the port to be reached through firewall and routers, and enable network on your phone using wifi.
User avatar
Yopia
Platinum Boarder
Platinum Boarder
 
Posts: 630

Re: Device App Loader url incorrect or not launch in ShiVa  [FIXED]

Postby Winin » 12 Apr 2011, 21:36

Ahhhh, I found the problem. I use Dropbox for my game dev, and so I was pointing to a folder in my Dropbox directory (a sub-dir of My Documents). I pointed to a regular, non-Dropbox folder, and it seems to be working now.

Thanks!
User avatar
Winin
Expert Boarder
Expert Boarder
 
Posts: 82
Location: San Francisco


Return to Bugs